6 de dezembro de 2011

Respostas Condicionais no Excel

É muito comum termos de colocar como resultado final de um cálculo, não o valor puro, mas sim uma resposta, composta por uma palavra ou sentença, condicionada ao resultado numérico obtido. A isso chamamos de Respostas Condicionais.



Um bom exemplo é o do controle de aprovação de uma classe de alunos. Se um aluno tirar média final maior, ou igual, a 5.0 ele estará APROVADO, em caso negativo estará REPROVADO.

Vamos à planilha que nos servirá como exemplo, adapte-a para atender às suas necessidades:



A B C D E
1 NOME NOTA1 NOTA2 MÉDIA RESULTADO
2 Francisco 7 9 8,0 APROVADO
3 José 3 8 5,5 APROVADO
4 Maria 7 4 5,5 APROVADO
5 Carla 5 7 6,0 APROVADO
6 Mota 5 4 4,5 REPROVADO

A nossa necessidade: colocar as expressões "Aprovado" ou "Reprovado" na coluna E, de acordo com a média final do aluno (que se encontra na coluna D). Como fazer? Simples, siga os passos abaixo:
  1. Coloque o cursor na célula E2 e digite a fórmula: =SE(D2>=5;"APROVADO";"REPROVADO");
  2. Copie a fórmula por todas as demais células da coluna E, no exemplo até a linha 6;
Pronto, já podemos saber e/ou mostrar quem passou e quem não, sem precisar prestar, muita, atenção aos números da coluna D.

Poderíamos colocar as respostas diferenciadas em azul (para os aprovados) e vermelho (para os reprovados).

Segue um esquema que funciona muito bem:
  1. Apague os dados da coluna E, ou crie uma nova coluna, a coluna F,
  2. Lá copie a referência para a célula correspondente à coluna das médias (coluna D):
    digite a fórmula =D2 na célula E2;
  3. Formate a célula exatamente como indicado nas 2 linhas abaixo:
    Menu Formatar * Células, aba Número, opção Personalizado; no campo Tipo digite exatamente:
    [Azul][>=5]"APROVADO";[Vermelho][<5]"REPROVADO"
  4. Copie a fórmula em E2 para o restante das linhas da coluna E, no exemplo até a linha 6;
Se voce tiver bastante cuidado com os colchetes, aspas, sinais (maior ou igual que, e menor que) e o ponto-e-vírgula, então o resultado final deverá ficar parecido com a tabela abaixo:


A B C D E
1 NOME NOTA1 NOTA2 MÉDIA RESULTADO
2 Francisco 7 9 8,0 APROVADO
3 José 3 8 5,5 APROVADO
4 Maria 7 4 5,5 APROVADO
5 Carla 5 7 6,0 APROVADO
6 Mota 5 4 4,5 REPROVADO

Quer aprender mais? Acesse Superdicas.com.br

0 comentário(s):

Postar um comentário